Creating a App Pen Scenario (Appvance Designer Script 3.0)
Pre-Requisite
Evaluation Guide:Recording a Appvance Designer Script from Designer 3.0
DB Connection should be tested successfully in Results page.(Logged in as Admin → Global Options → Admin Options → Results tab → Click Enabled Checkbox → Click Accept → Connection Status should be Successful)
Creating your first App Pen Scenario
- Open a browser, navigate to your Appvance IQ URL and login using your credentials
- Select the Build option
Scenario Editor appears
- Select File → New
- From the Info tab, click Please select a Test Type box and select App Penetration Test
- From the Test Cases tab, click Add a Test Case Execution
- Enter a name for the test case in the Test Case Name box
- Enter a name for the script in the Script Name box
- Click the Script Type box and select Appvance Test Designer
- Click Browse (to the right of the Resource box)
The Open window appears
- Select the Appvance Test Designer (file extension .ds) created in the prior Getting Started Guide, and click Open
The selected file appears in the Resource box
- Click the Browser box and select the browser to use for playback
- Click Save
- The test case appears in the Iteration 1 list.
- If you want specify the number of level App pen should penetrate then Goto the Integration tab (Scroll it down) and mentioned it in the Number of levels deep to index.
- Select File → Save
The Save window appears, displaying the Appvance Designer controller file system; not the local machine
- Browse to the desired directory, enter a name for the scenario in the FileName box and click Save
- To playback, click Play Scenario
The scenario execution status launches in a new tab, and a new browser window opens, using the browser indicated in the scenario configuration, which executes the specified Appvance Designer script.
- When the Status displays Execution done , click Test case(s) Executions
- Select the first result in the Test case(s) Executions list
The output details, errors, requests & responses display on the corresponding tabs
- Click the Output tab (left set of tabs, below Live Reports) to view Security reports pertaining to this scenario execution.